using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div>\s*\n\s*.*?<p class=.*?>(.*?)<\/p>\s*\n\s*.*?\s*\n\s*(?=(\<a class=\""a\""\>))";
string substitution = @"";
string input = @"<div>
<p class=""match""> this sentence should match </p>
some text
<a class=""a""> some text </a>
</div>
<div>
<p class=""match""> this sentence shouldnt match</p>
some text
<a class =""b""> some text </a>
</div>
<div>
<p class=""match""> this sentence should match </p>
some text
<a class=""a""> some text </a>
</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}