re = /<div>\s*\n\s*.*?<p class=.*?>(.*?)<\/p>\s*\n\s*.*?\s*\n\s*(?=(\<a class=\"a\"\>))/
str = '<div>
<p class="match"> this sentence should match </p>
some text
<a class="a"> some text </a>
</div>
<div>
<p class="match"> this sentence shouldnt match</p>
some text
<a class ="b"> some text </a>
</div>
<div>
<p class="match"> this sentence should match </p>
some text
<a class="a"> some text </a>
</div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result