using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"//?\s*\*[\s\S]*?\*\s*//?";
string substitution = @"";
string input = @"/** This comment gets removed with my regex */
// ** This comment has the double leadng-trailng slashes ** //";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}