use strict;
my $str = '/** This comment gets removed with my regex */
// ** This comment has the double leadng-trailng slashes ** //';
my $regex = qr~//?\s*\*[\s\S]*?\*\s*//?~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";