$re = '~//?\s*\*[\s\S]*?\*\s*//?~m';
$str = '/** This comment gets removed with my regex */
// ** This comment has the double leadng-trailng slashes ** //';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;