import Foundation
let pattern = #"//?\s*\*[\s\S]*?\*\s*//?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/** This comment gets removed with my regex */
// ** This comment has the double leadng-trailng slashes ** //
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)