using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(?=(((f|ht)tps?)\:\/\/?)(www\.?)))Nissan(?![^<\s]+)(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)";
string input = @"You know odoo become now http://www.odoo.com.
Nissan is car manufacter odoocompany.
<p>Nissan</p>
<p>Nissan is company and Nissan Micra is product</p>
<p><a href=""www.Nissan.com"">Nissan</a> is company and <span><a href=""www.Nissan.com"">Nissan</a></span> Micra is product</p>
<p><span>Nissan</span></p>
<p>Nissan is product <a href=""nissan.com"">Nissan</a> ignore Nissan</p>
<p><a href=""nissan.com""><span>Nissan</span></a></p>
<p>odoo is a name Company and Nissan Micra is a model of best selling.</p>
Company Nissan is a name. and Nissan Micra is model name.
Company <a href=""nissan.com""><span>Nissan</span></a> is a name. and Nissan Micra is model name.
This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}