import re
regex = re.compile(r"(?<!(?=(((f|ht)tps?)\:\/\/?)(www\.?)))Nissan(?![^<\s]+)(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)")
test_str = ("You know odoo become now http://www.odoo.com. \n"
"Nissan is car manufacter odoocompany.\n\n"
"<p>Nissan</p>\n"
"<p>Nissan is company and Nissan Micra is product</p>\n"
"<p><a href=\"www.Nissan.com\">Nissan</a> is company and <span><a href=\"www.Nissan.com\">Nissan</a></span> Micra is product</p>\n\n"
"<p><span>Nissan</span></p>\n"
"<p>Nissan is product <a href=\"nissan.com\">Nissan</a> ignore Nissan</p>\n"
"<p><a href=\"nissan.com\"><span>Nissan</span></a></p>\n\n\n"
"<p>odoo is a name Company and Nissan Micra is a model of best selling.</p>\n"
"Company Nissan is a name. and Nissan Micra is model name. \n"
"Company <a href=\"nissan.com\"><span>Nissan</span></a> is a name. and Nissan Micra is model name. \n"
"This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")