import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!(?=(((f|ht)tps?)\\:\\/\\/?)(www\\.?)))Nissan(?![^<\\s]+)(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\\n))*</(?:a|span)>)";
final String string = "You know odoo become now http://www.odoo.com. \n"
+ "Nissan is car manufacter odoocompany.\n\n"
+ "<p>Nissan</p>\n"
+ "<p>Nissan is company and Nissan Micra is product</p>\n"
+ "<p><a href=\"www.Nissan.com\">Nissan</a> is company and <span><a href=\"www.Nissan.com\">Nissan</a></span> Micra is product</p>\n\n"
+ "<p><span>Nissan</span></p>\n"
+ "<p>Nissan is product <a href=\"nissan.com\">Nissan</a> ignore Nissan</p>\n"
+ "<p><a href=\"nissan.com\"><span>Nissan</span></a></p>\n\n\n"
+ "<p>odoo is a name Company and Nissan Micra is a model of best selling.</p>\n"
+ "Company Nissan is a name. and Nissan Micra is model name. \n"
+ "Company <a href=\"nissan.com\"><span>Nissan</span></a> is a name. and Nissan Micra is model name. \n"
+ "This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}