#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\/]+\/statistics(?:\/?[^\/]+)*\/?$"
Local $sString = "folder1/statistics" & @CRLF & _
"folder1/statistics/test1/another_folder" & @CRLF & _
"folder1/statistics/test2" & @CRLF & _
"folder2/statistics" & @CRLF & _
"folder2/statistics/test1" & @CRLF & _
"folder2/statistics/test2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")