import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\/]+\\/statistics(?:\\/?[^\\/]+)*\\/?$";
final String string = "folder1/statistics\n"
+ "folder1/statistics/test1/another_folder\n"
+ "folder1/statistics/test2\n"
+ "folder2/statistics\n"
+ "folder2/statistics/test1\n"
+ "folder2/statistics/test2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}