using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\/]+\/statistics(?:\/?[^\/]+)*\/?$";
string input = @"folder1/statistics
folder1/statistics/test1/another_folder
folder1/statistics/test2
folder2/statistics
folder2/statistics/test1
folder2/statistics/test2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}