re = /^[^\/]+\/statistics(?:\/?[^\/]+)*\/?$/m
str = 'folder1/statistics
folder1/statistics/test1/another_folder
folder1/statistics/test2
folder2/statistics
folder2/statistics/test1
folder2/statistics/test2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end