#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\\autocites((?:\{[^}]*\}|\[[^]]*\])+)" & @CRLF & _
" "
Local $sString = "\autocites[a1][a2]{a3}[b1][b2]{b3}" & @CRLF & _
"\autocites[a1][a2]{a3}[b1][b2]{b3}[c1][c2]{c3}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")