re = /\\autocites((?:\{[^}]*\}|\[[^]]*\])+)
/x
str = '\\autocites[a1][a2]{a3}[b1][b2]{b3}
\\autocites[a1][a2]{a3}[b1][b2]{b3}[c1][c2]{c3}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end