package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)\\autocites((?:\{[^}]*\}|\[[^]]*\])+)
`)
var str = `\autocites[a1][a2]{a3}[b1][b2]{b3}
\autocites[a1][a2]{a3}[b1][b2]{b3}[c1][c2]{c3}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}