import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\autocites((?:\\{[^\\}]*\\}|\\[[^]]*\\])+)\n"
+ " ";
final String string = "\\autocites[a1][a2]{a3}[b1][b2]{b3}\n"
+ "\\autocites[a1][a2]{a3}[b1][b2]{b3}[c1][c2]{c3}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}