package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(<title>([^<>]*)<\/title>.*?<content>)`)
var str = `<xml>
<item>
<title>Title 1</title>
<content>Text 1</content>
</item>
<item>
<title>Title 2</title>
<content>Text 2</content>
</item>
</xml>`
var substitution = "\1\2 "
fmt.Println(re.ReplaceAllString(str, substitution))
}