$re = '/(<title>([^<>]*)<\/title>.*?<content>)/s';
$str = '<xml>
<item>
<title>Title 1</title>
<content>Text 1</content>
</item>
<item>
<title>Title 2</title>
<content>Text 2</content>
</item>
</xml>';
$subst = "\1\2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;