use strict;
my $str = '<xml>
<item>
<title>Title 1</title>
<content>Text 1</content>
</item>
<item>
<title>Title 2</title>
<content>Text 2</content>
</item>
</xml>';
my $regex = qr/(<title>([^<>]*)<\/title>.*?<content>)/sp;
my $subst = '\\1\\2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";