re = /\[button link=""(.*?)"".*?\] (.*?)\[\/button\]/
str = '[button link=""https://share.hsforms.com/1E8BqtG6XQVSlIe0piDmVWA34iy5"" type=""icon"" newwindow=""yes""] Download the Sales Enablement Scorecard Tool[/button]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end