import Foundation
let pattern = #"\[button link=""(.*?)"".*?\] (.*?)\[\/button\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[button link=""https://share.hsforms.com/1E8BqtG6XQVSlIe0piDmVWA34iy5"" type=""icon"" newwindow=""yes""] Download the Sales Enablement Scorecard Tool[/button]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}