// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\[button link=""(.*?)"".*?\] (.*?)\[\/button\]"#).unwrap();
let string = "[button link=\"\"https://share.hsforms.com/1E8BqtG6XQVSlIe0piDmVWA34iy5\"\" type=\"\"icon\"\" newwindow=\"\"yes\"\"] Download the Sales Enablement Scorecard Tool[/button]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}