import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:_T\\(\\\"[^\\\"]+\\\"\\).*?|L\\\"[^\\\"]+\\\".*?)?(?<!#include )(?<!_T\\(|L|\\\\)\\\"(.*?)\\\"(?<!\\\\\\\")";
final String string = "\"This is a MBCS string\"; // \"This is a MBCS string\" match\n"
+ "_T(\"This is maybe a unicode string\"); // no match\n"
+ "L\"This is a unicode string\"; // no match\n"
+ "\"These both\" + \"should match\"; // \"These both\" and \"should match\" match\n"
+ "\"This is a \\\"quoted\\\" string\"; // \"This is a \\\"quoted\\\" string\" match\n"
+ "_T(\"Maybe this\") + \"is a match\"; // \"is this\" match but instead would match \") + \"\n"
+ "do_something(_T(\"This doesn't match\")) + do_something(\"but this does match\"); // \"but this does match\" match but isntead it matches \")) + do_something(\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}