re = /(?:_T\(\"[^\"]+\"\).*?|L\"[^\"]+\".*?)?(?<!#include )(?<!_T\(|L|\\)\"(.*?)\"(?<!\\\")/
str = '"This is a MBCS string"; // "This is a MBCS string" match
_T("This is maybe a unicode string"); // no match
L"This is a unicode string"; // no match
"These both" + "should match"; // "These both" and "should match" match
"This is a \\"quoted\\" string"; // "This is a \\"quoted\\" string" match
_T("Maybe this") + "is a match"; // "is this" match but instead would match ") + "
do_something(_T("This doesn\'t match")) + do_something("but this does match"); // "but this does match" match but isntead it matches ")) + do_something("'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end