# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:_T\(\"[^\"]+\"\).*?|L\"[^\"]+\".*?)?(?<!#include )(?<!_T\(|L|\\)\"(.*?)\"(?<!\\\")"
test_str = ("\"This is a MBCS string\"; // \"This is a MBCS string\" match\n"
"_T(\"This is maybe a unicode string\"); // no match\n"
"L\"This is a unicode string\"; // no match\n"
"\"These both\" + \"should match\"; // \"These both\" and \"should match\" match\n"
"\"This is a \\\"quoted\\\" string\"; // \"This is a \\\"quoted\\\" string\" match\n"
"_T(\"Maybe this\") + \"is a match\"; // \"is this\" match but instead would match \") + \"\n"
"do_something(_T(\"This doesn't match\")) + do_something(\"but this does match\"); // \"but this does match\" match but isntead it matches \")) + do_something(\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.