const regex = new RegExp('(?:_T\\(\\"[^\\"]+\\"\\).*?|L\\"[^\\"]+\\".*?)?(?<!#include )(?<!_T\\(|L|\\\\)\\"(.*?)\\"(?<!\\\\\\")', 'g')
const str = `"This is a MBCS string"; // "This is a MBCS string" match
_T("This is maybe a unicode string"); // no match
L"This is a unicode string"; // no match
"These both" + "should match"; // "These both" and "should match" match
"This is a \\"quoted\\" string"; // "This is a \\"quoted\\" string" match
_T("Maybe this") + "is a match"; // "is this" match but instead would match ") + "
do_something(_T("This doesn't match")) + do_something("but this does match"); // "but this does match" match but isntead it matches ")) + do_something("`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}