using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\\\/]JAXB[\\\/].+?[\\\/]classes[\\\/][A-Z]";
string input = @"D:\workspace\Project\src\com\tj\JAXB\foo\bar/classes\FooClass.java";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}