$re = '/[\\\\\/]JAXB[\\\\\/].+?[\\\\\/]classes[\\\\\/][A-Z]/';
$str = 'D:\\workspace\\Project\\src\\com\\tj\\JAXB\\foo\\bar/classes\\FooClass.java';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);