package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\\\/]JAXB[\\\/].+?[\\\/]classes[\\\/][A-Z]`)
var str = `D:\workspace\Project\src\com\tj\JAXB\foo\bar/classes\FooClass.java`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}