using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name:(.*?)id:(.*?)unicode:(.*?)created:(.*?)categories:(.*?)(?=- name|$)";
string input = @"- name: Glass
id: glass
unicode: f000
created: 1.0
categories:
- Web Application Icons
- Test1
- Test2
- name: Music
id: music
unicode: f001
created: 1.0
categories:
- Web Application Icons
- name: Search
id: search
unicode: f002
created: 1.0
categories:
- Web Application Icons1
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}