const regex = new RegExp('name:(.*?)id:(.*?)unicode:(.*?)created:(.*?)categories:(.*?)(?=- name|$)', 'gs')
const str = `- name: Glass
id: glass
unicode: f000
created: 1.0
categories:
- Web Application Icons
- Test1
- Test2
- name: Music
id: music
unicode: f001
created: 1.0
categories:
- Web Application Icons
- name: Search
id: search
unicode: f002
created: 1.0
categories:
- Web Application Icons1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}