import re
regex = re.compile(r"name:(.*?)id:(.*?)unicode:(.*?)created:(.*?)categories:(.*?)(?=- name|$)", flags=re.DOTALL)
test_str = ("- name: Glass\n"
"id: glass\n"
"unicode: f000\n"
"created: 1.0\n"
"categories:\n"
" - Web Application Icons\n"
" - Test1\n"
" - Test2\n\n"
"- name: Music\n"
"id: music\n"
"unicode: f001\n"
"created: 1.0\n"
"categories:\n"
" - Web Application Icons\n\n"
"- name: Search\n"
"id: search\n"
"unicode: f002\n"
"created: 1.0\n"
"categories:\n"
" - Web Application Icons1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")