import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "name:(.*?)id:(.*?)unicode:(.*?)created:(.*?)categories:(.*?)(?=- name|$)";
final String string = "- name: Glass\n"
+ "id: glass\n"
+ "unicode: f000\n"
+ "created: 1.0\n"
+ "categories:\n"
+ " - Web Application Icons\n"
+ " - Test1\n"
+ " - Test2\n\n"
+ "- name: Music\n"
+ "id: music\n"
+ "unicode: f001\n"
+ "created: 1.0\n"
+ "categories:\n"
+ " - Web Application Icons\n\n"
+ "- name: Search\n"
+ "id: search\n"
+ "unicode: f002\n"
+ "created: 1.0\n"
+ "categories:\n"
+ " - Web Application Icons1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}