#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!unwanted.*)(?:^.{1,8}).*\s*(expression2 expression3)"
Local $sString = "string" & @CRLF & _
"expression2 expression3 // Matched..." & @CRLF & _
"" & @CRLF & _
"unwanted" & @CRLF & _
"expression2 expression3 // Not Matched..." & @CRLF & _
"" & @CRLF & _
"sdgfkjsdöfkjsdöfkjsdf" & @CRLF & _
"expression2 expression3 // Matched..." & @CRLF & _
"" & @CRLF & _
"unwanted sdasd" & @CRLF & _
"expression2 expression3 // Not Matched..." & @CRLF & _
"" & @CRLF & _
"string" & @CRLF & _
"expression2 expression3 // Matched..." & @CRLF & _
"" & @CRLF & _
"string" & @CRLF & _
"expression2 expression3 // Matched..." & @CRLF & _
"" & @CRLF & _
"unwanted" & @CRLF & _
"expression2 expression3 // Not Matched..." & @CRLF & _
"" & @CRLF & _
"string" & @CRLF & _
"expression2 expression3 // Matched..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")