const regex = /(?!unwanted.*)(?:^.{1,8}).*\s*(expression2 expression3)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!unwanted.*)(?:^.{1,8}).*\\s*(expression2 expression3)', 'gm')
const str = `string
expression2 expression3 // Matched...
unwanted
expression2 expression3 // Not Matched...
sdgfkjsdöfkjsdöfkjsdf
expression2 expression3 // Matched...
unwanted sdasd
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...
string
expression2 expression3 // Matched...
unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}