use strict;
my $str = 'string
expression2 expression3 // Matched...
unwanted
expression2 expression3 // Not Matched...
sdgfkjsdöfkjsdöfkjsdf
expression2 expression3 // Matched...
unwanted sdasd
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...
string
expression2 expression3 // Matched...
unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...';
my $regex = qr/(?!unwanted.*)(?:^.{1,8}).*\s*(expression2 expression3)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}