using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!unwanted.*)(?:^.{1,8}).*\s*(expression2 expression3)";
string input = @"string
expression2 expression3 // Matched...
unwanted
expression2 expression3 // Not Matched...
sdgfkjsdöfkjsdöfkjsdf
expression2 expression3 // Matched...
unwanted sdasd
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...
string
expression2 expression3 // Matched...
unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}