using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?\d*\.{0,1}\d+$";
string substitution = @"$1 $2";
string input = @"Bloodseeker-0.51%55.26%188,271 ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}