const regex = /^-?\d*\.{0,1}\d+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?\\d*\\.{0,1}\\d+$', '')
const str = `Bloodseeker-0.51%55.26%188,271 `;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);