use strict;
my $str = 'Bloodseeker-0.51%55.26%188,271 ';
my $regex = qr/^-?\d*\.{0,1}\d+$/p;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";