package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) - .*(*SKIP)(*F)| `)
var str = `My Beautiful Video - Hello darling - 19.10.2015 10:00`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}