// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) - .*(*SKIP)(*F)| ").unwrap();
let string = "My Beautiful Video - Hello darling - 19.10.2015 10:00";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}