import re
regex = re.compile(r" - .*(*SKIP)(*F)| ", flags=re.MULTILINE)
test_str = "My Beautiful Video - Hello darling - 19.10.2015 10:00"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)