re = / - .*(*SKIP)(*F)| /m
str = 'My Beautiful Video - Hello darling - 19.10.2015 10:00'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result