using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^word1(?!.*\b(?:word2|word3)\b).*$";
string input = @"word1 something, and more.
word1 word2 something, and more.
word1 word3 something, and more.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}