re = /^word1(?!.*\b(?:word2|word3)\b).*$/m
str = 'word1 something, and more.
word1 word2 something, and more.
word1 word3 something, and more.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end