$re = '/^word1(?!.*\b(?:word2|word3)\b).*$/m';
$str = 'word1 something, and more.
word1 word2 something, and more.
word1 word3 something, and more.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);