const regex = /^word1(?!.*\b(?:word2|word3)\b).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^word1(?!.*\\b(?:word2|word3)\\b).*$', 'gm')
const str = `word1 something, and more.
word1 word2 something, and more.
word1 word3 something, and more.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}