import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[^`]+>|<\\/\\w+>)";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ " <head>\n"
+ " <title>Hello</title>\n"
+ " </head>\n"
+ " <body>\n"
+ " <h1>hello</h1>\n"
+ " <h6>whatever</h6>\n"
+ " <p>this is a paragraph</p>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}